qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject Problem running qpid tests on windows.
Date Tue, 29 Jun 2010 14:46:44 GMT
Newbie question - attempting my first windows build from a clean trunk.

Got everything built, I can run qpidd and test clients like qpid-perftest no 
problem. However I can't run the test suite, specifically unit_test crashes with 
an unhandled exception.

I notice in my build that there's an extra "d" appended to the name of each dll:

  Directory of C:\Users\aconway\qpid\qpid\clean\src\Debug

06/28/2010  02:18 PM           686,080 qmfconsoled.dll
06/28/2010  02:23 PM           429,056 qmfd.dll
06/28/2010  02:23 PM         1,095,680 qmfengined.dll
06/28/2010  02:25 PM         4,495,360 qpidbrokerd.dll
06/28/2010  02:16 PM         1,489,920 qpidclientd.dll
06/28/2010  02:09 PM         3,409,408 qpidcommond.dll
06/28/2010  02:18 PM         1,096,704 qpidmessagingd.dll
06/28/2010  02:19 PM           152,064 qpidxarmd.dll
06/28/2010  02:26 PM           146,944 replicating_listenerd.dll
06/28/2010  02:26 PM            98,816 replication_exchanged.dll
               10 File(s)     13,100,032 bytes
                0 Dir(s)  84,880,236,544 bytes free

As far as I can tell, the extra "d" is the problem. Debugger shows unit_test 
bombs in Shlib::load with the name "replicating_listener.dll", but the file is 
called "replicating_listenered.dll". If I copy all the *d.dlls to just *.dll the 
test gets further, but spews error messages followed by an "Object Dump" - I 
haven't looked into that yet.

What is adding the extra "d"?


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message