qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Kennedy <andrewinternatio...@gmail.com>
Subject JRE/JDK Version
Date Tue, 01 Jun 2010 16:00:45 GMT
All,

What JDK/JRE environment do we want to target for the broker? The OSGi
plugins specify Java 5 as a minimum, and the ant build uses Java 5
compatibility when building, however, in the ServerSession class, we
use a ConcurrentSkipListMap, which is a Java 6 only class. I don't see
a big issue in changing to requiring Java 6, personally...

Andrew.
-- 
-- andrew d kennedy ? edinburgh : +44 7941 197 134

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message