qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Conway (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Edited] (QPID-3129) cluster_tests.LongTests.test_failover hangs
Date Thu, 24 Mar 2011 20:29:05 GMT

    [ https://issues.apache.org/jira/browse/QPID-3129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13010894#comment-13010894
] 

Alan Conway edited comment on QPID-3129 at 3/24/11 8:27 PM:
------------------------------------------------------------

Running with trace logging on, in all cases one of the clients (usually sender but sometimes
receiver) hangs with the last thing it says being something like:

2011-03-23 14:47:17 debug RECV [41935 10.16.44.237:41935] INIT(0-10)

Note that local and remote port on the connection are _the same_. This test is running on
a single host so clearly that's not a valid TCP connection. So far I have no idea why this
is happening but it seems to be the cause of the hang.

With trace logging on it takes more iterations to reproduce with -DDURATION=4, I'm seeing
up to 5.

      was (Author: aconway):
    Running with trace logging on, in all cases one of the clients (usually sender but sometimes
receiver) hangs with the last thing it says being something like:

2011-03-23 14:47:17 debug RECV [41935 10.16.44.237:41935] INIT(0-10)

Note: the local and remote port on the connection are _the same_. This test is running on
a single host so clearly that's not a valid TCP connection. So far I have no idea why this
is happening but it seems to be the cause of the hang.
  
> cluster_tests.LongTests.test_failover hangs 
> --------------------------------------------
>
>                 Key: QPID-3129
>                 URL: https://issues.apache.org/jira/browse/QPID-3129
>             Project: Qpid
>          Issue Type: Bug
>          Components: C++ Clustering
>    Affects Versions: 0.9
>            Reporter: Alan Conway
>            Assignee: Alan Conway
>            Priority: Minor
>             Fix For: 0.9
>
>
> The test cluster_tests.LongTests.test_failover hangs if run with duration of a minute
or more.
> To reproduce:
>   make check TESTS=run_cluster_tests CLUSTER_TESTS='cluster_tests.LongTests.test_failover
-DDURATION=1'
> Should pass after about 1 minute, but hangs indefinitely.
> This is probably a test bug.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message