qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: [JAVA] build breakage with older ant/java
Date Wed, 17 Aug 2011 19:21:15 GMT
I fixed the build breakage on Saturday when committing something else,
so you dont need to worry about that now.

The issue below is due to the somewhat ancient version of Ant you are
using; a commit some weeks ago has used an attribute not supported
until Ant 1.7.1, released in June 2008.

You say you cant update, but is that really the case? All that is
required to update Ant would be to unpack the ~6+ MB binary (e.g. from
http://www.apache.org/dist/ant/binaries/ ) and add the bin directory
to your path, job done. The alternative would be to rework the
additions to support 1.6.5, but at over 6 years old I think its time
we gave up on that and take advantage of the bug fixes and newer
features in later releases (theres a few I've spotted in 1.8.X that I
look forward to using at some point down the line, once its suitably
aged).

Robbie

On 17 August 2011 17:07, mick <mgoulish@redhat.com> wrote:
> I'm not a Java developer, although I do know how to break the build.
>
> Problem is -- when trying to fix my problem, I ran into a pre-existing
> problem:
> (with a new code tree as of this morning)
>
>
> [mick@mrg35 java]$ ant clean build
> Buildfile: build.xml
>    [mkdir] Created dir: /home/mick/trunk/qpid/java/tasks/classes
>    [javac] Compiling 5 source files
> to /home/mick/trunk/qpid/java/tasks/classes
>    [javac]
> Note: /home/mick/trunk/qpid/java/tasks/src/org/apache/qpid/tasks/BaseTask.java uses unchecked
or unsafe operations.
>    [javac] Note: Recompile with -Xlint:unchecked for details.
>
> BUILD FAILED
> /home/mick/trunk/qpid/java/build.xml:25: The following error occurred
> while executing this line:
> /home/mick/trunk/qpid/java/common.xml:122: The <dirset> type doesn't
> support the "erroronmissingdir" attribute.
>
> - - - - - - - - -
>
> I am using   java    java-1.6.0-openjdk-1.6.0.0-1.22.1.9.8.el5_6
> and ant    ant-1.6.5-2jpp.2
> ( and I do not have the choice of updating thses.)
>
>
> Does anyone know an easy way to work around this problem for these older
> versions?
>
>
>

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message