qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Stitcher <astitc...@redhat.com>
Subject Re: cmake build broken? (was Re: 0.14 release update - release branch and beta)
Date Fri, 04 Nov 2011 18:30:46 GMT
On Fri, 2011-11-04 at 11:20 +0000, Gordon Sim wrote:
> On 11/03/2011 10:47 PM, Justin Ross wrote:
> > Good evening.  A little later than I promised, I have branched from
> > trunk for release and produced the 0.14 beta.
> >
> > Beta revision: 1197313
> > Beta distribution: http://people.apache.org/~jross/qpid-0.14-beta/
> > Release branch: https://svn.apache.org/repos/asf/qpid/branches/0.14/
> 
> The cmake build doesn't seem to work for me, using 
> cmake-2.6.4-5.fc12.i686. I get lots of errors stating for 
> set_target_properties[1], it reports it can't find PerlLibs[2] though 
> the perl bindings built ok with autotools and the configuration is 
> reported as incomplete due to errors[3].
> 
> [1] set_target_properties called with incorrect number of arguments.
> [2] Could NOT find PerlLibs  (missing:  PERL_LIBRARY PERL_INCLUDE_PATH)
> [3] Configuring incomplete, errors occurred!

I think these are due to me/original submitter forgetting to add the new
cmake files in my recent check in. That is one of the least intuitive
things to remember.- that if you add new build files to cmake you have
to add them to the autotools build so they get added to the distribution
tgz.

https://issues.apache.org/jira/browse/QPID-3586

Andrew



---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message