qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Stitcher (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (QPID-3606) Qpid.pc pkgconfig file isn't sufficient to compile programs using qpid API
Date Thu, 10 Nov 2011 15:48:51 GMT
Qpid.pc pkgconfig file isn't sufficient to compile programs using qpid API
--------------------------------------------------------------------------

                 Key: QPID-3606
                 URL: https://issues.apache.org/jira/browse/QPID-3606
             Project: Qpid
          Issue Type: Bug
          Components: C++ Client
    Affects Versions: 0.14, 0.15
            Reporter: Andrew Stitcher


The pkg-config file currently supplied with qpid only has -lqpidmessing in its LDFLAGS and
omits -lqpidtypes.

This used to work in many Linux versions because libqpidmessaging has a dependency on libqpidtypes
itself so the library is pulled in. However newer versions of ld require that the link line
is complete for the applications direct needs and won't use transitive needs to fulfil needed
symbols.

The fix is simply to add -lqpidtypes as well

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message