qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Carda <dan.ca...@twtelecom.com>
Subject Re: Problem Deploying JCA Test Programs
Date Thu, 17 Nov 2011 18:32:53 GMT

Hey Weston,
I'll keep my eyes peeled for the next release.  However, I'm sure the
release I have is going to be more than adequate.

Last question: Of the five MDB message types (Stream, Map, Text, Object, and
Bytes) which are supported by the connector?  Obviously, Text is, but is
there any support for the others?

Many Thanks!
Dan




Weston M. Price wrote:
> 
> Hi Dan,
> 	Glad to hear your up and running! 
> 
> 	Currently the code you have was used in putting the adapter and the
> examples together prior to going upstream for review and eventual
> inclusion. We are planning on having the latest code upstream in short
> order, but the timing is not quite set. The code that you have should be
> fine in the interim, as there are no major changes in the later code base
> so what you have now should tie you over until everything is official. 
> 
> Thanks for the kinds word btw as well as checking out the adapter and
> running the examples. Any feedback, comments etc are greatly appreciated.
> 
> Regards,
> 
> Weston
> 
> 
> On Nov 17, 2011, at 12:27 PM, Dan Carda wrote:
> 
>> 
>> Thank you Weston,
>> I got it deploying and the run-client tests are running fine.  
>> 
>> Question: You said I have an older version?  Where do I get the most
>> recent
>> version from?   
>> 
>> BTW, good job on this entire module.  You guys did a great job.
>> 
>> Daniel
>> 
>> 
>> 
>> Weston M. Price wrote:
>>> 
>>> Hi Dan,
>>> 	I see, this is an older version of the adapter. The adapter hasn't
>>> officially been released upstream yet, but the examples you have should
>>> work just fine. Quick check of the code you have, the property in
>>> build.xml is actually called:
>>> 
>>> <property name="target.platform" value="geronimo"/>
>>> 
>>> simply modify this to be
>>> 
>>> <property name="target.platform" value="jboss"/>
>>> 
>>> and then
>>> 
>>> ant clean deploy-ds, deploy-rar, deploy-ear
>>> 
>>> One other property of note will be the 
>>> 
>>> <property name="broker.url"
>>> value="amqp://anonymous:@client/test?brokerlist='tcp://localhost:5672?sasl_mechs='ANONYMOUS''"/>
>>> 
>>> property. You will want to make sure this points to a valid broker for
>>> your environment. 
>>> 
>>> Any other issues please don't hesitate to let me know.
>>> 
>>> Regards,
>>> 
>>> Weston
>>> 
>>> 
>>> On Nov 17, 2011, at 11:32 AM, Dan Carda wrote:
>>> 
>>>> 
>>>> Hey Weston,
>>>> Wow, thanks for the fast response.
>>>> 
>>>> I acquired the adapter from here:
>>>> 
>>>>   https://github.com/astitcher/qpid-jca
>>>> 
>>>> Looks like this is the 0.10 version.   Is there a more current version?
>>>> 
>>>> I will look into that target container variable right now.
>>>> 
>>>> THANKS!!!
>>>> 
>>>> 
>>>> 
>>>> 
>>>> Weston M. Price wrote:
>>>>> 
>>>>> Hi Dan,
>>>>> 	It looks like from your syntax for your destination your using the
>>>>> Geronimo version of the examples:
>>>>> 
>>>>>> jca:/qpid.jca/QpidJCAAdapter/JCAAdminObject/HelloQueue
>>>>> 
>>>>> In your build.xml file you should see a property 
>>>>> 
>>>>> target.host
>>>>> 
>>>>> By default this is set to Geronimo, you simply need to change this to
>>>>> jboss and do a 
>>>>> 
>>>>> ant clean deploy-ds deploy-rar deploy-ear
>>>>> 
>>>>> Can I ask where you acquired the adapter and what version of the
>>>>> examples
>>>>> you are using just to be sure.
>>>>> 
>>>>> Regards,
>>>>> Weston
>>>>> 
>>>>> 
>>>>> On Nov 17, 2011, at 11:23 AM, Dan Carda wrote:
>>>>> 
>>>>>> 
>>>>>> Hi!  
>>>>>> Got a problem with the JCA adapter.  I'm basically building and
>>>>>> deploy
>>>>>> the
>>>>>> stock code.  The only exception is I went though and changed all
the
>>>>>> amqp
>>>>>> references to reflect our local bus.
>>>>>> 
>>>>>> I move the qpid-ra-0.10.rar to our JBoss 6.1's ./server/all/deploy
>>>>>> directory
>>>>>> and all is well.
>>>>>> 
>>>>>> Using the build.xml scripts. I deploy the qpid-jca-ds.xml (also to
>>>>>> the
>>>>>> ./server/all/deploy directory) and I get no problems.  The messages
I
>>>>>> see
>>>>>> on
>>>>>> the JBoss console seem to indicate the Topic and Queue are being
>>>>>> deployed.
>>>>>> 
>>>>>> However, when I try to deploy the client EJB I get this message:
>>>>>> 
>>>>>> 09:06:50,919 INFO  [org.apache.qpid.ra.inflow.QpidActivation]
>>>>>> Attempting
>>>>>> to
>>>>>> reconnect
>>>>>> org.apache.qpid.ra.inflow.QpidActivationSpec(ra=org.apache.qpid.ra.QpidResourceAdapter@356c414
>>>>>> destination=jca:/qpid.jca/QpidJCAAdapter/JCAAdminObject/HelloQueue
>>>>>> destinationType=javax.jms.Queue ack=Auto-acknowledge durable=false
>>>>>> clientID=null user=null maxSession=10)
>>>>>> 
>>>>>> 09:06:50,923 ERROR [org.apache.qpid.ra.inflow.QpidActivation] Unable
>>>>>> to
>>>>>> reconnect
>>>>>> org.apache.qpid.ra.inflow.QpidActivationSpec(ra=org.apache.qpid.ra.QpidResourceAdapter@356c414
>>>>>> destination=jca:/qpid.jca/QpidJCAAdapter/JCAAdminObject/HelloQueue
>>>>>> destinationType=javax.jms.Queue ack=Auto-acknowledge durable=false
>>>>>> clientID=null user=null maxSession=10):
>>>>>> javax.naming.NameNotFoundException:
>>>>>> jca: not bound
>>>>>> 
>>>>>> I know I'm doing something wrong but I just can see what?  I see
in
>>>>>> the
>>>>>> QpidListenerBean.java the "destination" is prefixed with jca, but
I
>>>>>> don't
>>>>>> know what to change to get the deploy working.
>>>>>> 
>>>>>> Any help would be MUCH appreciated.
>>>>>> 
>>>>>> Warm Regards,
>>>>>> Daniel Carda
>>>>>> 
>>>>>> -- 
>>>>>> View this message in context:
>>>>>> http://old.nabble.com/Problem-Deploying-JCA-Test-Programs-tp32863113p32863113.html
>>>>>> Sent from the Qpid Developers mailing list archive at Nabble.com.
>>>>> 
>>>>> 
>>>>> ---------------------------------------------------------------------
>>>>> Apache Qpid - AMQP Messaging Implementation
>>>>> Project:      http://qpid.apache.org
>>>>> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>>>>> 
>>>>> 
>>>>> 
>>>> 
>>>> -- 
>>>> View this message in context:
>>>> http://old.nabble.com/Problem-Deploying-JCA-Test-Programs-tp32863113p32863167.html
>>>> Sent from the Qpid Developers mailing list archive at Nabble.com.
>>>> 
>>>> 
>>>> ---------------------------------------------------------------------
>>>> Apache Qpid - AMQP Messaging Implementation
>>>> Project:      http://qpid.apache.org
>>>> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>>>> 
>>> 
>>> 
>>> ---------------------------------------------------------------------
>>> Apache Qpid - AMQP Messaging Implementation
>>> Project:      http://qpid.apache.org
>>> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>>> 
>>> 
>>> 
>> 
>> -- 
>> View this message in context:
>> http://old.nabble.com/Problem-Deploying-JCA-Test-Programs-tp32863113p32863524.html
>> Sent from the Qpid Developers mailing list archive at Nabble.com.
>> 
>> 
>> ---------------------------------------------------------------------
>> Apache Qpid - AMQP Messaging Implementation
>> Project:      http://qpid.apache.org
>> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>> 
> 
> 
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:dev-subscribe@qpid.apache.org
> 
> 
> 

-- 
View this message in context: http://old.nabble.com/Problem-Deploying-JCA-Test-Programs-tp32863113p32863919.html
Sent from the Qpid Developers mailing list archive at Nabble.com.


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message