qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Conway" <acon...@redhat.com>
Subject Re: Review Request: Develop Asynchronous Store Interface for Qpid (v.2)
Date Wed, 29 Feb 2012 14:43:00 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/4085/#review5455
-----------------------------------------------------------



branches/asyncstore/cpp/src/qpid/broker/AsyncInterface.h
<https://reviews.apache.org/r/4085/#comment11853>

    We should stick with our naming conventions. A type name is SomeType, not someType_t.
    
    Also FYI we have a generic opaque refcounted Handle templates which might be useful, see
include/qpid/messaging/Handle.h, src/qpid/messaging/PrivateImplRef.h



branches/asyncstore/cpp/src/qpid/broker/AsyncInterface.h
<https://reviews.apache.org/r/4085/#comment11854>

    I'm not keen on a single store-wide callback object. I would prefer to have the caller
pass in their callback object at the beginning when they submit their job, and then we call
back that object when the job is finished. That makes it much easier to implement post-actions
for the caller as they can bundle all the relevant data in the callback implementation.



branches/asyncstore/cpp/src/qpid/broker/AsyncInterface.h
<https://reviews.apache.org/r/4085/#comment11855>

    This is a factory functionI think createSuccessHandle is clearer than nextSuccessHandle.


- Alan


On 2012-02-28 16:29:47, Kim van der Riet wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/4085/
> -----------------------------------------------------------
> 
> (Updated 2012-02-28 16:29:47)
> 
> 
> Review request for qpid, Andrew Stitcher, Alan Conway, Gordon Sim, Kenneth Giusti, and
Ted Ross.
> 
> 
> Summary
> -------
> 
> This is the second design draft for an asyncronous store interface after feedback from
the previous review was received. (See QPID-3858 https://issues.apache.org/jira/browse/QPID-3858
for an overview.)
> 
> Much of the commentary is in the source. Comments are welcome.
> 
> 
> Diffs
> -----
> 
>   branches/asyncstore/cpp/src/CMakeLists.txt 1294116 
>   branches/asyncstore/cpp/src/Makefile.am 1294116 
>   branches/asyncstore/cpp/src/qpid/broker/AsyncInterface.h PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/4085/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Kim
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message