qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject Re: Windows test failures
Date Thu, 23 Feb 2012 15:44:30 GMT

On 02/22/2012 06:46 PM, Alan Conway wrote:
> I've committed a fix for error on windows "An operation was attempted on
> something that is not a socket." An ill-advised attempt to make socket
> errors more informative on my part. I'm still not able to run the full
> set of tests on windows so I'm not sure if I've covered all of the
> problems.
>

How do things look to you after this revision? It fixes the not-a-socket problem:

------------------------------------------------------------------------
r1292587 | aconway | 2012-02-22 18:46:48 -0500 (Wed, 22 Feb 2012) | 2 lines

NO-JIRA: Fix error on windows "An operation was attempted on something that is 
not a socket."

------------------------------------------------------------------------


> On Wed, 2012-02-22 at 10:48 -0600, Steve Huston wrote:
>> Right, the ipv6 test doesn't have a PowerShell script yet, and I think the
>> python missing module is a PYTHONPATH issue. The ones I was more concerned
>> with are coming from C++ code and are "operation attempted on an object
>> which is not a socket" or similar. The unit tests fails with this and at
>> least one other such as client_test.
>>
>> To run the tests under ctest control, cd to the build directory and
>>
>> ctest -R<test-expression>
>

I'm still having a lot of trouble with ctest. It will run a test for me about 
half the time, and just hang the other half. When it runs it takes an 
inexplicably long time, e.g. qpid-client-test took 56 seconds to run. If I run 
it by hand it's instantaneous.

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message