qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shammi Jayasinghe <sha...@wso2.com>
Subject Problem in Finding dependencies for jars used by Qpid
Date Fri, 03 Feb 2012 06:51:35 GMT
Hi ,

  We are trying to find out maven dependencies for the libraries
(qpid/java/lib) used in qpid trunk. We could find out the all the maven
dependencies and use them for
building qpid instead of following two libraries.

1. org.apache.felix.framework-2.0.5 jar [
http://mvnrepository.com/artifact/org.apache.felix/org.apache.felix.framework/2.0.5
]
2. jython-2.5.0.jar [
http://search.maven.org/#artifactdetails|org.python|jython|2.5.0|jar]

Though we were able to find out these libraries in the mentioned
repositories , it seems there are some difference in the content of those
libraries
though they seems to be the same version.

jython
--------
check_jython_deps:

jython:
     [java] *sys-package-mgr*: processing new jar,
'/home/shammi/wso2/qpid/trunk/qpid/java/lib/jython-2.5.0.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/resources.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/rt.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/jsse.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/jce.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/charsets.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/ext/sunjce_provider.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/ext/localedata.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/ext/dnsns.jar'
     [java] *sys-package-mgr*: processing new jar,
'/opt/software/jdk1.6.0_21/jre/lib/ext/sunpkcs11.jar'
     [java] Traceback (most recent call last):
     [java]   File "/home/shammi/wso2/qpid/trunk/qpid/java/common/codegen",
line 22, in <module>
     [java]     import os, sys, mllib
     [java] ImportError: No module named os

BUILD FAILED


Felix
-------

[javac]
^
    [javac]
/home/shammi/wso2/qpid/trunk/qpid/java/broker/src/main/java/org/apache/qpid/server/plugins/PluginManager.java:241:
cannot find symbol
    [javac] symbol  : method
process(org.apache.felix.framework.util.StringMap,org.osgi.framework.BundleContext)
    [javac] location: class org.apache.qpid.server.plugins.PluginManager
    [javac]                 process(configMap, _felix.getBundleContext());
    [javac]                 ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 15 errors

BUILD FAILED


We would like to know that is there any modifications done on those two
libraries by qpid team and please let us know where we can find the
exact  maven dependency used for the above libraries.

Thanks in advance,
Best Regards,*

Shammi Jayasinghe*
Senior Software Engineer; WSO2, Inc.; http://wso2.com,
mobile: +94 71 4493085

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message