qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Stitcher <astitc...@redhat.com>
Subject Re: cmake build issues
Date Thu, 24 May 2012 00:07:20 GMT
On Wed, 2012-05-23 at 18:43 -0400, Rajith Attapattu wrote:
> I'm getting compile errors when trying to build using cmake.
> 
> Ex.
> 
> /home/rajith/workspace/git-qpid/qpid/qpid/cpp/src/qpid/client/LoadPlugins.cpp:
> In constructor
> ‘qpid::client::{anonymous}::LoadtimeInitialise::LoadtimeInitialise()’:
> /home/rajith/workspace/git-qpid/qpid/qpid/cpp/src/qpid/client/LoadPlugins.cpp:42:38:
> error: ‘QPIDC_CONF_FILE’ was not declared in this scope
> /home/rajith/workspace/git-qpid/qpid/qpid/cpp/src/qpid/client/LoadPlugins.cpp:43:43:
> error: ‘QPIDC_MODULE_DIR’ was not declared in this scope
> make[2]: *** [src/CMakeFiles/qpidclient.dir/qpid/client/LoadPlugins.o]
> Error 1
> make[1]: *** [src/CMakeFiles/qpidclient.dir/all] Error 2
> 
> It's possible I might have missed a step.
> Any ideas what I might be missing ?

Would you give a complete list of what you have done? It's pretty hard
to diagnose otherwise.

The proximate cause here though is that the config.h file has not been
correctly generated. Did you try to run cmake from the qpid/cpp
directory itself? If so I don't think that will work.

I use cmake builds for most of my work and I don't have this problem.

Andrew



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message