qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Conway (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (QPID-4118) HA does not work with auhentication and authorization.
Date Wed, 11 Jul 2012 15:58:34 GMT

    [ https://issues.apache.org/jira/browse/QPID-4118?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13411650#comment-13411650
] 

Alan Conway edited comment on QPID-4118 at 7/11/12 3:57 PM:
------------------------------------------------------------

Merged to 0.18 

r1360227 | aconway | 2012-07-11 11:26:28 -0400 (Wed, 11 Jul 2012) | 7 lines

QPID-4118: HA does not work with authentication and authorization.

- Updated test framework to use credentials
- Updated BrokerReplicator to use HA identity to create configuration
- Updated documentation with a HA security section.
- Updated qpid-ha to take --sasl-mechanism


                
      was (Author: aconway):
    
r1360228 | aconway | 2012-07-11 11:26:36 -0400 (Wed, 11 Jul 2012) | 9 lines

QPID-4128: HA should not use amq.failover for replication links

HA replication links should not use the amq.failover exchange to get updates
reconnect targets. amq.failover provides the client failover list, HA manages a
separate failover list for brokers. Replication links should be using the broker
list, and not allow it to be overwritten by amq.failover updates.

Review requested for 0.18, 2 line fix.



                  
> HA does not work with auhentication and authorization.
> ------------------------------------------------------
>
>                 Key: QPID-4118
>                 URL: https://issues.apache.org/jira/browse/QPID-4118
>             Project: Qpid
>          Issue Type: Bug
>          Components: C++ Clustering
>    Affects Versions: 0.17
>            Reporter: Alan Conway
>            Assignee: Alan Conway
>
> If authentication and ACL are enabled on brokers in a HA cluster, backup brokers
> are unable to replicate even if --ha-username etc. are set to a user with all priviledges.
> Need to correct this, and update the documentation explaining what permissions are required
to run a secure HA cluster.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message