qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Rudyy (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (QPID-4109) Reenable LoggingManagement MBean
Date Thu, 05 Jul 2012 14:26:34 GMT

    [ https://issues.apache.org/jira/browse/QPID-4109?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13407159#comment-13407159
] 

Alex Rudyy edited comment on QPID-4109 at 7/5/12 2:25 PM:
----------------------------------------------------------

Hi Keith,
I reviewed your code.

The changes looks good for me. I have only some minor comments which I provided below:

1) I would change the name of class LoggingFacade into LoggingManagementFacade or LoggingConfigFacade.
IMHO, LoggingFacade name is too generic

2)I would change LoggingFacade#getAvailableLoggerLevels and LoggingManagementMBean#getAvailableLoggerLevels.
IMHO, creation of new instance of list on every invocation of getAvailableLoggerLevels is
not not so effective,  as declaring a constant for available logger levels and returning the
reference to that constant in getAvailableLoggerLevels.
 
3)LoggingManagementMBean#validateLevelNotAllowingInherited

It looks like the first condition in if statement is redundant.
I would change it to something like
{code}
        if (level == null || !availableLoggerLevels.contains(level.toUpperCase()))
        {
            throw new IllegalArgumentException(level + " not known");
        }
{code}

Keith,
What do you think about the above comments?
                
      was (Author: alex.rufous):
    Hi Keith,
I reviewed your code.

The changes looks good for me. I have only some minor comments which I provided below:

1) I would change the name of the class LoggingFacade into LoggingManagementFacade or LoggingConfigFacade.
IMHO, LoggingFacade name is to generic

2)I would change LoggingFacade#getAvailableLoggerLevels and LoggingManagementMBean#getAvailableLoggerLevels.
IMHO, creation of new instance of list on every invocation of getAvailableLoggerLevels is
not not so effective,  as declaring a constant for available logger levels and returning the
reference to the constant in getAvailableLoggerLevels.
 
3)LoggingManagementMBean#validateLevelNotAllowingInherited

It looks like the first condition in if statement is redundant.
I would change it something like
{code}
        if (level == null || !availableLoggerLevels.contains(level.toUpperCase()))
        {
            throw new IllegalArgumentException(level + " not known");
        }
{code}

Keith,
What do you think about the above comments?
                  
> Reenable LoggingManagement MBean
> --------------------------------
>
>                 Key: QPID-4109
>                 URL: https://issues.apache.org/jira/browse/QPID-4109
>             Project: Qpid
>          Issue Type: Task
>          Components: Java Broker, Java Management : JMX Console
>    Affects Versions: 0.17
>            Reporter: Keith Wall
>            Assignee: Alex Rudyy
>             Fix For: 0.17
>
>
> QPID-4093 temporarily removed the LoggingManagement MBean from the JMX management interface.
 This change is to re-add the bean.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message