qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kenneth Giusti" <kgiu...@apache.org>
Subject Review Request: QPID tools fail when using SSL on some older versions of python (QPID-4337)
Date Fri, 21 Sep 2012 14:33:55 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/7207/
-----------------------------------------------------------

Review request for qpid and Rafael Schloming.


Description
-------

This patch adds support to QPID python clients for SSL using older versions of python (pre-2.6).

It allows our QPID tools to be used over SSL, both with and without client authentication,
on systems that have pre 2.6 python support.


This addresses bug qpid-4337.
    https://issues.apache.org/jira/browse/qpid-4337


Diffs
-----

  /trunk/qpid/extras/qmf/src/py/qmf/console.py 1388232 
  /trunk/qpid/python/qpid/messaging/transports.py 1388232 
  /trunk/qpid/python/qpid/util.py 1388232 

Diff: https://reviews.apache.org/r/7207/diff/


Testing
-------

Tested each of the QPID tools on Centos 5, using non-ssl, ssl, and ssl w/client authentication.
 E.G.:

qpid-config -b amqp://somehost:5672
qpid-config -b amqps://somehost:5671
qpid-config -b amqps://somehost:5671 --ssl-certificate foo.cert


Thanks,

Kenneth Giusti


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message