qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Matos <bruno.ma...@paradigmaxis.pt>
Subject VC10 x64 client libs compilation
Date Wed, 10 Oct 2012 13:01:49 GMT
Hi,

I have compiled Qpid 0.18 64-bit client libs (qpidtypes, qpidcommon, 
qpidclient and qpidmessaging) using vc10, but I had to make some little 
changes that I would like to share. Comments are welcome and appreciated.

1. I used boost 1.51.0 64-bit so I had to make some minor changes on 
Modules.cpp to use the new filesystem 3 API. I had also to comment 
src/CMakeLists.txt line 1471 
"add_definitions(-DBOOST_FILESYSTEM_VERSION=2)" for the reason above (I 
don't know the real impact of this).

2. Regarding to VC10, I had to change the main CMakeLists.txt line 39 
from 'add_definitions(/w44996)' to 'set (CMAKE_CXX_FLAGS 
"${CMAKE_CXX_FLAGS} /w44996")', again without knowing the real impact of 
this.
I still have a warning: 'system runtime library file does not exist', 
but the compilation ends without errors, so I think I can ignore it.

I have used QtCreator 2.4.0, CMake 2.8.7 and NMake Generator (Microsoft 
Windows SDK for Windows 7 (7.1) (x64).

I can make a patch if someone thinks it would be useful.

Regards,
Bruno Matos

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message