qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: qpid-queue-stats not giving statistics for all the queues ??
Date Wed, 29 May 2013 08:20:18 GMT
On 05/29/2013 07:19 AM, RajendraNPTL wrote:
> hello Every one..
> i tried to know the enqueue and dequeue rates of queues in my Qpid c++
> broker. Then, i used this command
>
> $qpid-queue-stats
>
> But, it's giving statistics of only two queues.
> like this...
>
> qmfc-v2-ui-localhost.3728.1                      10.00          0
> 0.10         0.10
> topic-localhost.3728.1                           10.00          0
> 0.20         0.20
> qmfc-v2-ui-localhost.3728.1                      10.00          0
> 0.10         0.10
> topic-localhost.3728.1                           10.00          0
> 0.20         0.20
> qmfc-v2-ui-localhost.3728.1                      10.00          0
> 0.10         0.10
> topic-localhost.3728.1                           10.00          0
> 0.20         0.20
> qmfc-v2-ui-localhost.3728.1                      10.00          0
> 0.10         0.10
> topic-localhost.3728.1                           10.00          0
> 0.20         0.20
> ..........continues......
>
> I want to get the statistics of all the queues in broker.
> Also its good if i get statistics of a particular queue(Specified by me).
> Any idea is appreciated ..

That sounds like there are no other queues with active traffic. Try 
qpid-stat -q and make sure you are connecting to the correct broker 
instance.

To filter the queues you are monitoring, use the --filter option.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message