qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: [VOTE] Release 0.22 RC6 as 0.22 final
Date Thu, 30 May 2013 12:57:48 GMT
On 05/30/2013 01:42 PM, Darryl L. Pierce wrote:
> On Thu, May 30, 2013 at 01:35:52PM +0100, Gordon Sim wrote:
>> On 05/26/2013 11:35 AM, Justin Ross wrote:
>>> RC6 contains the proposed final bits for Qpid 0.22.
>>>
>>> If you favor making the RC6 bits into our official release, vote +1.
>>> If you have reason to believe RC6 is not ready for release, vote -1.
>>
>> +1
>>
>> However using the cmake build, I hit an install failure when using a
>> non-standard install location because the qmfgen libraries do not
>> seem to honour the specified prefix. Is this a known issue?
>
> Do you mean with using DESTDIR=$somedir ?

Using CMAKE_INSTALL_PREFIX.

> I'm not seeing any install failures during packaging. The RPM packaging
> system uses a non-standard location to install the bits before
> generating the RPMs.

I see:

> Install the project...
> -- Install configuration: ""
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/share/doc/qpid-cpp-0.22/LICENSE
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/share/doc/qpid-cpp-0.22/NOTICE
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/share/qpid/qpid/qpid.i
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/share/qpid/qpid/swig_perl_typemaps.i
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/share/qpid/qpid/swig_python_typemaps.i
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/share/qpid/qpid/swig_ruby_typemaps.i
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/include/qmf/qmfengine.i
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/include/qmf/qmf2.i
> -- Installing: /home/gordon/qpid-releases/0.22rc6/TEST_INSTALL/bin/qmf-gen
> CMake Error at managementgen/cmake_install.cmake:48 (FILE):
>   file cannot create directory: /usr/lib/python2.7/site-packages/qmfgen.

These seem not to get installed into my required location as are the 
earlier artefacts above.

>   Maybe need administrative privileges.
> Call Stack (most recent call first):
>   cmake_install.cmake:60 (INCLUDE)



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message