qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Ross (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (QPID-2316) 0.6RC2 C++ Build fails if ruby-dev and swig installed
Date Tue, 13 Aug 2013 10:06:48 GMT

     [ https://issues.apache.org/jira/browse/QPID-2316?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Justin Ross closed QPID-2316.
-----------------------------

    
> 0.6RC2 C++ Build fails if ruby-dev and swig installed
> -----------------------------------------------------
>
>                 Key: QPID-2316
>                 URL: https://issues.apache.org/jira/browse/QPID-2316
>             Project: Qpid
>          Issue Type: Bug
>          Components: Build Tools
>    Affects Versions: 0.6, 0.7
>            Reporter: Rob Godfrey
>            Assignee: Ted Ross
>
> When attempting to build the C++ contained in the artefact at 
> http://qpid.apache.org/dist/qpid-0.6rc2/qpid-0.6rc2.tar.gz
> I got the following error on my machine:
> Making all in ruby
> make[2]: Entering directory `/home/rob/qpidc-0.6/bindings/qmf/ruby'
> make[2]: *** No rule to make target `ruby.i', needed by `qmfengine.cpp'.  Stop.
> Further investigation showed that the build succeeded on a separate machine, however
on this machine the qmfengine.cpp target was commented out in the buildfile.  This was as
a result of the fact that the second machine did not have ruby development and SWIG packages
installed.  After installing these packages the second machine failed in the same way as the
first

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message