qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Evans (JIRA)" <j...@apache.org>
Subject [jira] [Created] (QPID-5303) AMQP 1.0 -> 0-10 doesn't map 'exchange' delivery property
Date Wed, 06 Nov 2013 20:59:17 GMT
Daniel Evans created QPID-5303:
----------------------------------

             Summary: AMQP 1.0 -> 0-10 doesn't map 'exchange' delivery property
                 Key: QPID-5303
                 URL: https://issues.apache.org/jira/browse/QPID-5303
             Project: Qpid
          Issue Type: Bug
            Reporter: Daniel Evans


When a publisher publishes an AMQP 1.0 message to an exchange (i.e. amqp://0.0.0.0/someExchange),
a regular AMQP 0-10 subscriber will be delivered a message that doesn't include the exchange
delivery property. 

Since the translation here seems to be intending to present the "normal" users of the broker
with the same model regardless of whether the message source was 1.0, I'm assuming it would
be more correct to have that delivery property set. We use it in some of our AMQP applications.

I poked around and part of the problem seems to be that the name of the exchange resolved
from the 1.0 address has long been discarded by the time the broker is delivering the message
from the queue.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message