qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Darryl L. Pierce (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-5338) The Dispatch top-level Python package should be renamed
Date Fri, 15 Nov 2013 18:35:20 GMT

    [ https://issues.apache.org/jira/browse/QPID-5338?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13823915#comment-13823915
] 

Darryl L. Pierce commented on QPID-5338:
----------------------------------------

The package naming convention discourages using underscores [1]. That said, the name for the
package IMO so much about the directory tree for the sources as it is a namespace to avoid
collisions with other Python code.

Sorry about the empty directories, it's a git->svn glitch that I'll clean that up shortly.

[1] http://www.python.org/dev/peps/pep-0008/#package-and-module-names

> The Dispatch top-level Python package should be renamed
> -------------------------------------------------------
>
>                 Key: QPID-5338
>                 URL: https://issues.apache.org/jira/browse/QPID-5338
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Qpid Dispatch
>            Reporter: Darryl L. Pierce
>            Assignee: Darryl L. Pierce
>             Fix For: Future
>
>
> Currently the package name is qpid, which conflicts with the public qpid Python package
library. A better idea would be to rename it qpiddx.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message