qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-5351) Settle on one prefix for Dispatch names
Date Tue, 19 Nov 2013 19:27:25 GMT

    [ https://issues.apache.org/jira/browse/QPID-5351?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13826840#comment-13826840

ASF subversion and git services commented on QPID-5351:

Commit 1543541 from [~tedross] in branch 'dispatch/trunk'
[ https://svn.apache.org/r1543541 ]

QPID-5351 - Missing in last commit

> Settle on one prefix for Dispatch names
> ---------------------------------------
>                 Key: QPID-5351
>                 URL: https://issues.apache.org/jira/browse/QPID-5351
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Qpid Dispatch
>            Reporter: Justin Ross
>            Assignee: Ted Ross
>         Attachments: consistent-naming.patch
> When we have a chance to clarify a true connection for our users by
> using a consistent convention, we should.  Here's what we have now:
> {noformat}
>   qpid-dxrouter.conf
>   qpid-dxrouterd
>   qdstat
>   dx_ for C symbols
>   qdx for AMQP addresses
> {noformat}
> A mess!  I propose one of the following:
> {noformat}
>   dxrouterd.conf         qdxrouterd.conf        qdrouterd.conf
>   dxrouterd              qdxrouterd             qdrouterd
>   dxstat                 qdxstat                qdstat
>   dx_ for symbols        qdx_ for symbols       qd_ for symbols
>   dx for addresses       qdx for addresses      qd for addresses
> {noformat}
> Expressed as a rule: where it's sensible to use a short form, always
> use "qd" (or whatever ends up being canonical).  Otherwise, spell it
> out: qpid/dispatch.
> A standard prefix also improves command-line discoverability:
> qd[TAB][TAB] shows you all the entrypoints.
> I slightly prefer "qd" because it's the simplest abbreviation of Qpid
> Dispatch.  The patch attached here uses it, but I am quite willing to
> supply a new set of patches that use another prefix.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org

View raw message