qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Stitcher (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-5646) Can't build against any released version of proton
Date Wed, 02 Apr 2014 14:19:16 GMT

    [ https://issues.apache.org/jira/browse/QPID-5646?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13957676#comment-13957676
] 

Andrew Stitcher commented on QPID-5646:
---------------------------------------

RHEL 5 does not come with cmake 2.8 so this is not related to RHEL 5.
All currently released versions of RHEL come with cmake 2.6. (Perhaps this is from EPEL?)

The IF block protecting the message is supposed to just not run that line on versions of cmake
that don't support the ... CONFIG_MODE... syntax. So try the patch changing it to "2.8.3"
(I don't know that is correct but we can iterate until we get to the correct version).

> Can't build against any released version of proton
> --------------------------------------------------
>
>                 Key: QPID-5646
>                 URL: https://issues.apache.org/jira/browse/QPID-5646
>             Project: Qpid
>          Issue Type: Bug
>          Components: C++ Broker, C++ Client
>    Affects Versions: 0.28, 0.29
>            Reporter: Gordon Sim
>            Assignee: Andrew Stitcher
>            Priority: Blocker
>             Fix For: 0.28, 0.29
>
>         Attachments: FindProton.cmake.diff
>
>
> as a result of changes for QPID-5631.
> Both trunk and beta need to be able to build against a released version of proton.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message