qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Godfrey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-5889) Reading from Service Bus via Qpid JMS client fails
Date Wed, 16 Jul 2014 13:37:05 GMT

    [ https://issues.apache.org/jira/browse/QPID-5889?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14063491#comment-14063491
] 

Rob Godfrey commented on QPID-5889:
-----------------------------------

Since we know lots of people are using the JMS client successfully with ServiceBus I don't
think your problem is likely to be a bug in the client code.

Are you sure you have the queue/topic names correctly set up on ServiceBus with the same names
you are using in your client program?

In order to aid debugging, have you turned on logging in the JMS client... (see instructions
here as to how to do so: http://mail-archives.apache.org/mod_mbox/qpid-users/201402.mbox/%3CCACsaS94QyZbYrScWNtChgk=Gn3oJDzgSL5sk5rrNVoJ9iZj7Eg@mail.gmail.com%3E
).

Feel free to attach the log output here (removing any confidential information such as usernames/passwords
that may be in the log)... However we don't actually have accounts on ServiceBus to test against
it.



> Reading from Service Bus via Qpid JMS client fails
> --------------------------------------------------
>
>                 Key: QPID-5889
>                 URL: https://issues.apache.org/jira/browse/QPID-5889
>             Project: Qpid
>          Issue Type: Bug
>          Components: Java Client
>    Affects Versions: 0.28
>            Reporter: Jurica Krizanic
>              Labels: servicebus
>
> I am trying to connect to Windows Service Bus from Qpid JMS Java client. Authentication
and handshake pass successfully, but I can not read anything from a  topic or queue.
> I am using your example provided at http://svn.apache.org/repos/asf/qpid/branches/0.28/qpid/java/amqp-1-0-client-jms/example/src/main/java/org/apache/qpid/amqp_1_0/jms/example/Hello.java
> Getting the error:
> The server was unable to process the request; please retry the operation. If the problem
persists, please contact your Service Bus administrator and provide the tracking id..TrackingId:584da4f8a98d4fa59dc9521c6f799cb8_GWIN-AN5B307EEHM,TimeStamp:11.7.2014.
8:12:24
> I have examined the source and I see the ReceivingLinkEndpoint instance gets to a detached
state, so it throws an exception.
> Could that be a bug? 
> Can you provide an example which works with Windows Service Bus?



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message