qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Python3 Support for qpid.messaging and BrokerAgent
Date Thu, 07 Aug 2014 10:45:06 GMT
On 08/06/2014 07:49 PM, Brian Bouterse wrote:
> I'm a developer who uses qpid.messaging and BrokerAgent, a class provided by the qpidtoollibs
Python package. Both of these are pure Python libraries. I'm considering using these with
Python3. Here are my questions:
>
> 1) Does qpid.messaging support Python3?

No, I think it would need some changes to be able to run with Python3 
(e.g. except syntax etc). At present qpid.messaging is tied in with the 
older qpid.* APIs; that's where the first issues seem to be from a very 
brief experiment.

> 2) Does BrokerAgent support Python3?

This obviously has qpid.messaging as a dependency, but I suspect it 
would not pose additional problems of its own with regards to Python3 as 
it is pretty simple.



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message