qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPIDJMS-23) upgrade findbugs-maven-plugin usage to 3.0.0 to enable use with Java 8
Date Thu, 07 Aug 2014 14:58:13 GMT

    [ https://issues.apache.org/jira/browse/QPIDJMS-23?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14089298#comment-14089298
] 

ASF subversion and git services commented on QPIDJMS-23:
--------------------------------------------------------

Commit 1616501 from [~gemmellr] in branch 'jms/trunk'
[ https://svn.apache.org/r1616501 ]

QPIDJMS-23: update to use findbugs[-maven-plugin] 3.0.0

> upgrade findbugs-maven-plugin usage to 3.0.0 to enable use with Java 8
> ----------------------------------------------------------------------
>
>                 Key: QPIDJMS-23
>                 URL: https://issues.apache.org/jira/browse/QPIDJMS-23
>             Project: Qpid JMS
>          Issue Type: Task
>            Reporter: Robbie Gemmell
>            Assignee: Robbie Gemmell
>
> The version of findbugs-maven-plugin currently being used in the site report uses findbugs
2.x, which is not compatible with Java 8. Findbugs 3.0.0 is Java 8 comptible and was recently
released.
> The findbugs-maven-plugin 3.0.0 release uses findbugs 3.0.0 and is compatible with Java8,
but is not yet available in maven central. We should use it once it is. The findbugs report
will be moved to an optional profile in the mean time.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message