qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fred Cheng (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Deleted] (QPID-6266) qpid-cpp-0.30 Build Fail - Org.Apache.Qpid.Messaging.dll
Date Wed, 24 Dec 2014 07:30:13 GMT

     [ https://issues.apache.org/jira/browse/QPID-6266?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Fred Cheng updated QPID-6266:
-----------------------------
    Comment: was deleted

(was: Hi Chunk,

Sorry to keep bothering you. 


All the DDLs are x64 since CMake used x64 VC++ compiler.  The org.apache.message solution
was the only one that gave me options to build either win32 or x64.  I have 


While I am building qpid-cpp 0.30, I had to make fixes to the linker library/dependencies
to compile qpidmessenger.dll.  This also happens to be the dll that is throwing the build
error in org.apache.messaging.  The original Linker -> Input has the following lines

Files/Proton/lib/qpid-proton.lib.lib
Program.lib
Files/Proton/lib/qpid-protond.lib.lib

1. There appears to be an extra .lib attached to qpid-proton.lib.  So I removed the extra
.lib.
2. Since I am just trying to get the debug one to work for now, I removed the line with qpid-proton.lib
3. I could not find "program.lib" so I removed it.  

Question 1. >> Is program.lib necessary? where do I get it? 

I am using the boost files from your link -> boost-win-1.52-64bit-vs2010.zip
Question 2. >> The build are reading header files from a win32 (..\boost\x64\include\boost-1_52\boost/thread/win32/)
directory, will that matter?

Question 3. >> The build throws the warning C4251 when it tries to link to the boost
header.

Question 4. >> Should I use a different set of boost files?  They worked for me on CMake,
but seem to have issues during build of qpidmessage and amqp projects)

> qpid-cpp-0.30 Build Fail - Org.Apache.Qpid.Messaging.dll
> --------------------------------------------------------
>
>                 Key: QPID-6266
>                 URL: https://issues.apache.org/jira/browse/QPID-6266
>             Project: Qpid
>          Issue Type: Bug
>          Components: Dot Net Client
>    Affects Versions: 0.30
>         Environment: Windows XP (x86)
> Windows 7 ( x64).  
> Visual Studios 2008, 2010
>            Reporter: Fred Cheng
>            Assignee: Chuck Rolke
>   Original Estimate: 120h
>  Remaining Estimate: 120h
>
> The build instructions in the file INSTALL-WINDOWS in qpid-cpp-0.30 does not work.  For
example, the file said to install 
> 1. CMake 2.4 
> 2. "cmake -i -G "Visual Studio 9 2008"
> The problem is the CMake 2.4 does not support "Visual Studio 9 2008"
> A second example is that the command -i  for cmake has been depreciated in current version
of cmake.  
> The file README-winsdk.txt also appears to be outdated.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message