qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "An Yang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-6285) ha plugin depends on rdma plugin
Date Wed, 24 Dec 2014 01:25:13 GMT

    [ https://issues.apache.org/jira/browse/QPID-6285?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14257780#comment-14257780
] 

An Yang commented on QPID-6285:
-------------------------------

I move ha.so to rha.so, qpidd loads ha.so before rdma.so, and i got new problem.
the third node is in active mode, but the second keep in joining mode, and first node drop
into  reconnect the primary dead loop.

but when use tcp transport, these nodes works fine.

> ha plugin depends on rdma plugin
> --------------------------------
>
>                 Key: QPID-6285
>                 URL: https://issues.apache.org/jira/browse/QPID-6285
>             Project: Qpid
>          Issue Type: Bug
>          Components: C++ Broker
>    Affects Versions: 0.22, 0.30
>         Environment: RHEL/Centos 6.6
>            Reporter: An Yang
>              Labels: HighAvailibility, plugins, rdma
>
> when i configure qpid-ha cluster with rdma transport, qpid failed to start.
> ha-cluster=yes
> ha-public-url=amqp:rdma:192.168.2.250
> ha-brokers-url=amqp:rdma:192.168.1.10,rdma:192.168.1.11,rdma:192.168.1.12
> qpid load ha plugin before rdma plugin, so could not get rdma support.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message