qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Godfrey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-6626) [Java Broker] Provide a mechanism for the REST API to communicate which versions are supported
Date Tue, 07 Jul 2015 22:36:05 GMT

    [ https://issues.apache.org/jira/browse/QPID-6626?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14617561#comment-14617561
] 

Rob Godfrey commented on QPID-6626:
-----------------------------------

1. I don't think it actually makes things any harder in as much as you need to know about
the structure to make use of this, in which case you would also know about the leading v -
but I do agree it's ugly, so I'll fix 
2. I'll fix this

> [Java Broker] Provide a mechanism for the REST API to communicate which versions are
supported
> ----------------------------------------------------------------------------------------------
>
>                 Key: QPID-6626
>                 URL: https://issues.apache.org/jira/browse/QPID-6626
>             Project: Qpid
>          Issue Type: Improvement
>            Reporter: Rob Godfrey
>            Assignee: Rob Godfrey
>             Fix For: 6.0 [Java]
>
>
> The REST API has a notion of version, and it is planned that future releases will provide
some limited capability to support prior versions of the API, however there is currently no
easy way to determine the versions of the API supported by a given broker



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message