qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lorenz Quack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-6728) Upgrade SLF4J dependency from 1.6 to 1.7
Date Thu, 10 Sep 2015 12:38:46 GMT

    [ https://issues.apache.org/jira/browse/QPID-6728?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14738680#comment-14738680
] 

Lorenz Quack commented on QPID-6728:
------------------------------------

I think you missed one instance of "new Object[]" in org.apache.qpid.server.store.berkeleydb.AbstractBDBMessageStore#storeMetaData

Other than that it looks good!


> Upgrade SLF4J dependency from 1.6 to 1.7
> ----------------------------------------
>
>                 Key: QPID-6728
>                 URL: https://issues.apache.org/jira/browse/QPID-6728
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Java Broker, Java Client, Java Common
>            Reporter: Keith Wall
>            Assignee: Lorenz Quack
>             Fix For: qpid-java-6.0
>
>
> Upgrade SLF4J dependency from 1.6 to 1.7.  The 1.7 line has been around for almost three
years and is widely used in the community.  It brings the advantage varargs style logging
methods without sacrificing binary compatibility - which makes logging code less verbose.
> Users of qpid-client who wish to use older SLF4J dependencies will be unaffected by this
change.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message