qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Rudyy (JIRA)" <j...@apache.org>
Subject [jira] [Created] (QPID-6772) [Java] logback license is reported as incompatible
Date Tue, 06 Oct 2015 08:33:26 GMT
Alex Rudyy created QPID-6772:
--------------------------------

             Summary: [Java] logback license is reported as incompatible
                 Key: QPID-6772
                 URL: https://issues.apache.org/jira/browse/QPID-6772
             Project: Qpid
          Issue Type: Bug
          Components: Java Broker, Java Client
            Reporter: Alex Rudyy
            Priority: Blocker


mvn package -P dependency-check  is flagging our use of logback as license incompatible. 
Now, logback is dual license LGNU and Eclipse Public License - the latter is compatible with
Apache in binary form
It seems the problem is simple the name of the license differs slightly so we are not detecting
it as acceptable.
 
{noformat}
 [INFO] Included licenses (whitelist): [Apache Software License, Version 2.0, The MIT License,
BSD License, Eclipse Public License - Version 1.0, Common Public License Version 1.0, Academic
Free License v2.1]
[WARNING] There is 3 forbidden licenses used:
[WARNING] License Unknown license used by 1 dependencies:
 -slf4j-api (org.slf4j:slf4j-api:1.7.12 - no url defined)
[WARNING] License Eclipse Public License - v 1.0used by 2 dependencies:
 -Logback Classic Module (ch.qos.logback:logback-classic:1.1.3 - http://logback.
qos.ch/logback-classic)
 -Logback Core Module (ch.qos.logback:logback-core:1.1.3 - http://logback.qos.ch
/logback-core)
[WARNING] License GNU Lesser General Public Licenseused by 2 dependencies:
 -Logback Classic Module (ch.qos.logback:logback-classic:1.1.3 - http://logback.
qos.ch/logback-classic)
 -Logback Core Module (ch.qos.logback:logback-core:1.1.3 - http://logback.qos.ch
/logback-core)
 {noformat}
 The logback issue is "Eclipse Public License - Version 1.0" != "License Eclipse Public License
- v 1.0"
 
We might need an additional "licenseMerge" in the configuration of license-maven-plugin
 





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message