qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Richardson (JIRA)" <j...@apache.org>
Subject [jira] [Created] (QPID-6821) Python tools scripts should specify correct python version in shebang
Date Mon, 02 Nov 2015 10:58:27 GMT
Chris Richardson created QPID-6821:
--------------------------------------

             Summary: Python tools scripts should specify correct python version in shebang
                 Key: QPID-6821
                 URL: https://issues.apache.org/jira/browse/QPID-6821
             Project: Qpid
          Issue Type: Bug
          Components: Python Tools
    Affects Versions: 0.32
         Environment: Linux, python 2.7 and python 3.4
            Reporter: Chris Richardson
             Fix For: qpid-tools-next


In systems with both python2 and python3 installed, with python3 as the default, qpid-tools
scripts (qpid-stat, qpid-config etc) fail due to being executed with the unsupported python3
VM. If the scripts require python2, should they not specify this in their shebangs, eg:
#!/bin/env python2
rather than
#!/bin/env python
?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message