qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lorenz Quack (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (QPID-6842) [Java Broker] AMQP 0-9 NullPointerException in ConsumerLoggingTest#testSubscriptionCreateWithArguments()
Date Fri, 13 Nov 2015 10:27:11 GMT

     [ https://issues.apache.org/jira/browse/QPID-6842?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lorenz Quack updated QPID-6842:
-------------------------------
    Description: 
I got the following NullPointerException when running the test ConsumerLoggingTest#testSubscriptionCreateWithArguments
with memory 0-9 profile:
{noformat}
java.lang.NullPointerException: null
        at org.apache.qpid.server.transport.SelectorThread$SelectionTask$1.run(SelectorThread.java:191)
~[qpid-broker-core-6.0.0-SNAPSHOT.jar:6.0.0-SNAPSHOT]
        at org.apache.qpid.server.transport.SelectorThread.run(SelectorThread.java:448) ~[qpid-broker-core-6.0.0-SNAPSHOT.jar:6.0.0-SNAPSHOT]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
~[na:1.8.0_60]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
~[na:1.8.0_60]
        at java.lang.Thread.run(Thread.java:745) ~[na:1.8.0_60]
{noformat}

I had some additional (unrelated) logging in the code when this occurred, therefor the line
numbers are a little bit off.
Also you will see the additional logging (starting with "LQ:") in the log file.

Unfortunately, I have not been able to reproduce the problem.


  was:
I got the following NullPointerException when running the test ConsumerLoggingTest#testSubscriptionCreateWithArguments
with memory 0-10 profile:
{noformat}
java.lang.NullPointerException: null
        at org.apache.qpid.server.transport.SelectorThread$SelectionTask$1.run(SelectorThread.java:191)
~[qpid-broker-core-6.0.0-SNAPSHOT.jar:6.0.0-SNAPSHOT]
        at org.apache.qpid.server.transport.SelectorThread.run(SelectorThread.java:448) ~[qpid-broker-core-6.0.0-SNAPSHOT.jar:6.0.0-SNAPSHOT]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
~[na:1.8.0_60]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
~[na:1.8.0_60]
        at java.lang.Thread.run(Thread.java:745) ~[na:1.8.0_60]
{noformat}

I had some additional (unrelated) logging in the code when this occurred, therefor the line
numbers are a little bit off.
Also you will see the additional logging (starting with "LQ:") in the log file.

Unfortunately, I have not been able to reproduce the problem.



> [Java Broker] AMQP 0-9 NullPointerException in ConsumerLoggingTest#testSubscriptionCreateWithArguments()
> --------------------------------------------------------------------------------------------------------
>
>                 Key: QPID-6842
>                 URL: https://issues.apache.org/jira/browse/QPID-6842
>             Project: Qpid
>          Issue Type: Bug
>          Components: Java Broker
>            Reporter: Lorenz Quack
>         Attachments: TEST-org.apache.qpid.server.logging.ConsumerLoggingTest.testSubscriptionCreateWithArguments.txt
>
>
> I got the following NullPointerException when running the test ConsumerLoggingTest#testSubscriptionCreateWithArguments
with memory 0-9 profile:
> {noformat}
> java.lang.NullPointerException: null
>         at org.apache.qpid.server.transport.SelectorThread$SelectionTask$1.run(SelectorThread.java:191)
~[qpid-broker-core-6.0.0-SNAPSHOT.jar:6.0.0-SNAPSHOT]
>         at org.apache.qpid.server.transport.SelectorThread.run(SelectorThread.java:448)
~[qpid-broker-core-6.0.0-SNAPSHOT.jar:6.0.0-SNAPSHOT]
>         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
~[na:1.8.0_60]
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
~[na:1.8.0_60]
>         at java.lang.Thread.run(Thread.java:745) ~[na:1.8.0_60]
> {noformat}
> I had some additional (unrelated) logging in the code when this occurred, therefor the
line numbers are a little bit off.
> Also you will see the additional logging (starting with "LQ:") in the log file.
> Unfortunately, I have not been able to reproduce the problem.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message