qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robbie Gemmell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PROTON-1224) Proton-J SSL uses deprecated Bouncy Castle functionality
Date Mon, 06 Jun 2016 16:47:20 GMT

    [ https://issues.apache.org/jira/browse/PROTON-1224?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15316741#comment-15316741
] 

Robbie Gemmell commented on PROTON-1224:
----------------------------------------

Copying comment from the PR since JIRA was actually down earlier when I commented on the PR.

{noformat}
The CI builds are failing while running the cmake build (using it is outlined in DEVELOPERS.md)
rather than the maven build. The cmake
build creates a proton-j jar by itself for use in certain tests, a process which these changes
break through introduction of a compile time
dependency on bouncycastle that it doesn't accommodate because it didn't previously need to.
Either the update needs to be made
fully-reflective as before, or the cmake build updated to accommodate the new compilation
dependency.

Some more general comments:
-  The main module and tests are specifying difference versions of bouncycastle to use.
-   If you include the JIRA title in the PR title, it will be updated by a bot upon PR open/comments/close.
-   Please reference the JIRA in commit msg, i.e "PROTON-XYZ: msg".
-   Please remove merge commits from PRs.

(Mentioning PROTON-1224 so it also gets updated)
{noformat}

> Proton-J SSL uses deprecated Bouncy Castle functionality
> --------------------------------------------------------
>
>                 Key: PROTON-1224
>                 URL: https://issues.apache.org/jira/browse/PROTON-1224
>             Project: Qpid Proton
>          Issue Type: Improvement
>          Components: proton-j
>    Affects Versions: 0.12.2
>            Reporter: Jem Day
>
> The BouncyCastle project deprecated functionality used by the proton-j driver in version
1.48. This causes run-time issues for us as our application containers are using newer BC
versions.
> I've submitted a PR for this change and verified that all tests run using both BC 1.48
and 1.54.
> Note: The CI pipeline for the PR is flagging an error but i am able to build/test locally
with no reported errors - build log is attached to the PR comments.
> https://github.com/apache/qpid-proton/pull/74



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message