qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chuck Rolke <cro...@redhat.com>
Subject Re: [jira] [Closed] (DISPATCH-764) Cannot receive from a multicast address
Date Fri, 05 May 2017 13:45:58 GMT
I ran into this same issue yesterday. My sender send rate nearly doubled and overall CPU fell
to 8% of what it used to be. Unfortunatley I was now testing the sender's reject rate and
no receiver received anything.

Setting 'router / allowUnsettledMulticast: true' put things back on track.

----- Original Message -----
> From: "Jiri Danek (JIRA)" <jira@apache.org>
> To: dev@qpid.apache.org
> Sent: Friday, May 5, 2017 1:26:04 AM
> Subject: [jira] [Closed] (DISPATCH-764) Cannot receive from a multicast address
> 
> 
>      [
>      https://issues.apache.org/jira/browse/DISPATCH-764?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
>      ]
> 
> Jiri Danek closed DISPATCH-764.
> -------------------------------
>     Resolution: Not A Bug
> 
> My mistake, the simple_send.py does not print the error it is getting, which
> is
> 
> Condition: qd:forbidden
> Description: Deliveries to a multicast address must be pre-settled
> 
> So it is only the result of change of behavior implemented in DISPATCH-744.
> 
> > Cannot receive from a multicast address
> > ---------------------------------------
> >
> >                 Key: DISPATCH-764
> >                 URL: https://issues.apache.org/jira/browse/DISPATCH-764
> >             Project: Qpid Dispatch
> >          Issue Type: Bug
> >    Affects Versions: 1.0.0
> >            Reporter: Jiri Danek
> >            Priority: Critical
> >
> > 1) Start qdrouterd with the default config (listens on localhost, defines
> > `multicast` address prefix)
> > 2) {{qpid-proton/examples/python/simple_recv.py -a 127.0.0.1:5672/multicast
> > -m 1}}
> > 3) {{qpid-proton/examples/python/simple_send.py -a 127.0.0.1:5672/multicast
> > -m 1}}
> > The message sent in step 3) is not received and printed by receiver started
> > in step 2).
> > This used to work in version 0.7.0 and in version 0.8.0, it does not work
> > for me in git tip build (what is to be 1.0.0).
> > Since this seems such a basic scenario, I have doubts if it is really a
> > bug. Maybe the behavior of the feature just changed, or I am doing
> > something wrong.
> 
> 
> 
> --
> This message was sent by Atlassian JIRA
> (v6.3.15#6346)
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
> For additional commands, e-mail: dev-help@qpid.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message