qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Rudyy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (QPID-7772) Add statistics panel to view tabs within the Web Management Console
Date Fri, 15 Sep 2017 11:51:00 GMT

    [ https://issues.apache.org/jira/browse/QPID-7772?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16167762#comment-16167762

Alex Rudyy commented on QPID-7772:

Here are my review comments for the implemented changes:

* Scroll position jumps to statistics grid on page refresh after focusing of any of statistics
grits (for example, due to sorting by Name) and scrolling down the tab. Explicit change of
the focus into other non statistics widget does not helps. The focus changes back to the statistics
grid.  This is an undesired effect. The current widget focus should not change on refreshes.
* Removal of statistics flattening 
** dots are displayed in grids for columns where statistics is displayed
*** VH tab:  queues, exchanges and loggers
*** Connection tab : sessions
* Statistics Widget
** Field allGrid is initalized to [] and field _nodes is initialized to {}. This kind of initialization
ends up in sharing of the same objects  by all instances of StatisticsWidget.
** We have fields (category, type, management) which are required to pass into constructor
and optional constructor field defaultStatistics. Additionally there are template and other
fields, for example, "userPreferences" which initialized in postConstruct. I think that we
can add a comment for fields without underscore about how they are set. For example, for category,
type, management we can add comment that they are set from mandatory constructor arguments
whilst fields like msgBytePairCumulativeStatisticsGridContainer are set from template. I think
that  userPreferences should be renamed into  _userPreferences as it is not set from template
or constructor.
** StatisticsWidget#postCreate
*** constructor arguments for _msgBytePairCumulativeStatisticsGrid of type EnhancedGrid declares
field 'class'. I think that class field should be quoted as class is reserved javascript world.
** Button caption "Show more statistics" looks too long to me. IMHO, substitution it with
"More" should be sufficient to understand the button purpose, as it is inside of title pane
with title 'Statistics', On toggle 'Less' can be displayed.
* Tabs
** IMHO, Tab CO attributes which are displayed at the right should be aligned to the top.
They are displayed in the middle
** Exchange tab layout is surprising (existing issue): attributes Type, State, Durable, Lifespan
are grouped together in a separate div. I am not sure that it is intentional. The same applies
to queue tab layout.
** VH tab contains 2 'alignLeft' groups. Is it intentional?

> Add statistics panel to view tabs within the Web Management Console
> -------------------------------------------------------------------
>                 Key: QPID-7772
>                 URL: https://issues.apache.org/jira/browse/QPID-7772
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Java Broker
>            Reporter: Keith Wall
>            Assignee: Keith Wall
>            Priority: Minor
>             Fix For: qpid-java-broker-7.0.0
> Configured Objects within the Broker's object model already carry many useful statistics.
 Only a fraction of these are currently presented on the WMC and this means that most users
are aware of their existence. 
>  Each view tab should have an expandable panel that provides the available statistics.
The contents of the statistics panel should be entirely driven from the object's metadata.
 If the statistics panel is opened, the statistics should be updated automatically to the
same refresh cycle of the request of the UI.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org

View raw message