qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Ross (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PROTON-1560) Cannot install qpid_proton-0.18.0.gem
Date Thu, 28 Sep 2017 14:51:00 GMT

    [ https://issues.apache.org/jira/browse/PROTON-1560?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16184282#comment-16184282
] 

Justin Ross commented on PROTON-1560:
-------------------------------------

[~aconway], this is resolved, true?

> Cannot install qpid_proton-0.18.0.gem
> -------------------------------------
>
>                 Key: PROTON-1560
>                 URL: https://issues.apache.org/jira/browse/PROTON-1560
>             Project: Qpid Proton
>          Issue Type: Bug
>          Components: ruby-binding
>            Reporter: Alan Conway
>            Assignee: Alan Conway
>             Fix For: proton-c-0.18.0
>
>
> Snapshot of master at commit 8c3ba5.
> When using these specific flags, compilation fails:
> CONFIGURE_ARGS='--with-cflags='\''-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches   -m64 -mtune=generic'\''
'
> + gem install -V --local --install-dir ./usr/share/gems --bindir ./usr/bin --force --document=ri,rdoc
qpid_proton-0.18.0.gem
> ....
> gcc -I. -I/usr/include -I/usr/include/ruby/backward -I/usr/include -I. -DHAVE_PROTON_ENGINE_H
-DHAVE_PROTON_MESSAGE_H -DHAVE_PROTON_SASL_H -DHAVE_PROTON_MESSENGER_H    -fPIC -O2 -g -pipe
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4
-grecord-gcc-switches   -m64 -mtune=generic -DRUBY20 -m64 -o cproton.o -c cproton.c
> Linked Applications
> JBoss Issue Tracker
>     Dashboards
>     Projects
>     Issues
>     Boards
>     Portfolio
>     Create
>     Help
>     Administration
>     User profile for Alan Conway
> AMQ ClientsIcon indicating the project type
> AMQ Clients
> A-MQ Clients
>     Backlog
>     Active sprints
>     Releases
>     Reports
>     Issues
>     Components
> Uploaded image for project: 'AMQ Clients'
>     AMQ ClientsENTMQCL-530
> Cannot install qpid_proton-0.18.0.gem
>     Edit
>     Comment
>     Assign
>     More
>     Ready for Dev
>     Closed
>     Export
> Details
>     Type:
>     Task
>     Status:
>     Ready for Triage (View Workflow)
>     Priority:
>     Major
>     Resolution:
>     Unresolved
>     Affects Version/s:
>     Future GA
>     Fix Version/s:
>     None
>     Component/s:
>     proton-c
>     Labels:
>     None
>     Environment:
>     RHEL 7, RPM Build
> Description
> Snapshot of master at commit 8c3ba5.
> When using these specific flags, compilation fails:
> CONFIGURE_ARGS='--with-cflags='\''-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic'\''
'
> + gem install -V --local --install-dir ./usr/share/gems --bindir ./usr/bin --force --document=ri,rdoc
qpid_proton-0.18.0.gem
> ....
> gcc -I. -I/usr/include -I/usr/include/ruby/backward -I/usr/include -I. -DHAVE_PROTON_ENGINE_H
-DHAVE_PROTON_MESSAGE_H -DHAVE_PROTON_SASL_H -DHAVE_PROTON_MESSENGER_H -fPIC -O2 -g -pipe
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4
-grecord-gcc-switches -m64 -mtune=generic -DRUBY20 -m64 -o cproton.o -c cproton.c
> ....
> cproton.c:6540:12: warning: 'check_trace' defined but not used [-Wunused-function]
> static int check_trace(int x) {
> ^
> make: *** [cproton.o] Error 1
> ERROR: Error installing qpid_proton-0.18.0.gem:
> ERROR: Failed to build gem native extension.
> Building has failed. See above output for more information on the failure.
> Attachments
> Drop files to attach, or
> Activity
>     All
>     Comments
>     Work Log
>     History
>     Activity
>     Links Hierarchy
>     Linked Cases
> There are no comments yet on this issue.
>     Comment
> People
>     Assignee:
>         aconway Alan Conway 
>     Reporter:
>         iboverma Irina Boverman 
>     Votes:
>         0 Vote for this issue 
>     Watchers:
>         1
>         Start watching this issue 
> Dates
>     Created:
>         4 days ago 
>     Updated:
>         2 days ago 
> Agile
>     View on Board
> ....
> cproton.c:6540:12: warning: 'check_trace' defined but not used [-Wunused-function]
>  static int check_trace(int x) {
>             ^
> make: *** [cproton.o] Error 1
> ERROR:  Error installing qpid_proton-0.18.0.gem:
> ERROR: Failed to build gem native extension.
> Building has failed. See above output for more information on the failure.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message