qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Blomquist (JIRA)" <j...@apache.org>
Subject [jira] [Created] (PROTON-1660) The gemspec dependency on "json ~> 0" breaks anyone dependning on a recent version of json
Date Fri, 27 Oct 2017 14:29:00 GMT
Greg Blomquist created PROTON-1660:
--------------------------------------

             Summary: The gemspec dependency on "json ~> 0" breaks anyone dependning on
a recent version of json
                 Key: PROTON-1660
                 URL: https://issues.apache.org/jira/browse/PROTON-1660
             Project: Qpid Proton
          Issue Type: Bug
            Reporter: Greg Blomquist


https://github.com/apache/qpid-proton/blob/0790bb99fabc4a6d7c1c12fb09c0ff76a3594f5a/proton-c/bindings/ruby/qpid_proton.gemspec.in#L31


This line was recently changed in qpid-proton master. It causes any project that depends on
a recent version of json to break when pulling together dependencies. The pessimistic style
of version constraint means that qpid-proton requires a json version of >= 0.0, but <
1. 

For instance, our project has a dependency on json 2.x. And, we see this error when bundling
with qpid-proton: 

{code:text} 
Bundler could not find compatible versions for gem "json": 
  In Gemfile: manageiq-providers-azure was resolved to 0.1.0, 
  which depends on azure-armrest (~> 0.9.1) was resolved to 0.9.1, which depends on json
(~> 2.0.1) 
  qpid_proton (~> 0.18) was resolved to 0.18.0, which depends on json (~> 0) 
{code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message