qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Frey (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (PROTON-1660) The gemspec dependency on "json ~> 0" breaks anyone dependning on a recent version of json
Date Fri, 27 Oct 2017 17:02:00 GMT

    [ https://issues.apache.org/jira/browse/PROTON-1660?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16222675#comment-16222675
] 

Jason Frey edited comment on PROTON-1660 at 10/27/17 5:01 PM:
--------------------------------------------------------------

FYI, on my system where I have json_pure also installed, I am seeing the following error:

{code:ruby}
Fetching: json-0.4.3.gem (100%)
json's executable "edit_json.rb" conflicts with json_pure
Overwrite the executable? [yN]  n
ERROR:  Error installing qpid_proton:
	"edit_json.rb" from json conflicts with installed executable from json_pure
{code}

But that's because it resolves to 0.4.3 instead of the latest 2.1.0


was (Author: fryguy):
FYI, on my system where I have json_pure also installed, I am seeing the following error:

```
Fetching: json-0.4.3.gem (100%)
json's executable "edit_json.rb" conflicts with json_pure
Overwrite the executable? [yN]  n
ERROR:  Error installing qpid_proton:
	"edit_json.rb" from json conflicts with installed executable from json_pure
```

But that's because it resolves to 0.4.3 instead of the latest 2.1.0

> The gemspec dependency on "json ~> 0" breaks anyone dependning on a recent version
of json
> ------------------------------------------------------------------------------------------
>
>                 Key: PROTON-1660
>                 URL: https://issues.apache.org/jira/browse/PROTON-1660
>             Project: Qpid Proton
>          Issue Type: Bug
>          Components: ruby-binding
>            Reporter: Greg Blomquist
>            Assignee: Alan Conway
>             Fix For: proton-c-0.18.1
>
>
> https://github.com/apache/qpid-proton/blob/0790bb99fabc4a6d7c1c12fb09c0ff76a3594f5a/proton-c/bindings/ruby/qpid_proton.gemspec.in#L31

> This line was recently changed in qpid-proton master. It causes any project that depends
on a recent version of json to break when pulling together dependencies. The pessimistic style
of version constraint means that qpid-proton requires a json version of >= 0.0, but <
1. 
> For instance, our project has a dependency on json 2.x. And, we see this error when bundling
with qpid-proton: 
> {code:none} 
> Bundler could not find compatible versions for gem "json": 
>   In Gemfile: manageiq-providers-azure was resolved to 0.1.0, 
>   which depends on azure-armrest (~> 0.9.1) was resolved to 0.9.1, which depends on
json (~> 2.0.1) 
>   qpid_proton (~> 0.18) was resolved to 0.18.0, which depends on json (~> 0) 
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message