qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ganesh Murthy (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DISPATCH-919) Display a warning when running Dispatch tests if python-unittest2 is not installed
Date Thu, 25 Jan 2018 14:43:00 GMT

     [ https://issues.apache.org/jira/browse/DISPATCH-919?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ganesh Murthy updated DISPATCH-919:
-----------------------------------
    Description: 
Because of changes made to DISPATCH-894 we now require python-unittest2 package to be installed
to be able to run the system tests. For anyone moving from Dispatch 1.0.0 to 1.1.0, this information
is not obvious. (we do have this information in the readme)

Please display a visible warning (python-unittest2 needs to be installed in order to run tests)
when a unit test is run (or if the entire test suite is run) without having python-unittest2
installed.

  was:
Because of changes made to DISPATCH-894 we now require python-unittest2 package to be installed
to be able to run the system tests. For anyone moving from Dispatch 1.0.0 to 1.1.0, this information
is not obvious. 

Please display a visible warning (python-unittest2 needs to be installed in order to run tests)
when a unit test is run (or if the entire test suite is run) without having python-unittest2
installed.


> Display a warning when running Dispatch tests if python-unittest2 is not installed
> ----------------------------------------------------------------------------------
>
>                 Key: DISPATCH-919
>                 URL: https://issues.apache.org/jira/browse/DISPATCH-919
>             Project: Qpid Dispatch
>          Issue Type: Bug
>          Components: Tests
>    Affects Versions: 1.0.0
>            Reporter: Ganesh Murthy
>            Assignee: Ganesh Murthy
>            Priority: Minor
>
> Because of changes made to DISPATCH-894 we now require python-unittest2 package to be
installed to be able to run the system tests. For anyone moving from Dispatch 1.0.0 to 1.1.0,
this information is not obvious. (we do have this information in the readme)
> Please display a visible warning (python-unittest2 needs to be installed in order to
run tests) when a unit test is run (or if the entire test suite is run) without having python-unittest2
installed.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message