qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Conway (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PROTON-1760) [ruby-binding] the package name on rubygems.org does not follow conventions
Date Wed, 28 Feb 2018 18:52:00 GMT

    [ https://issues.apache.org/jira/browse/PROTON-1760?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16380823#comment-16380823
] 

Alan Conway commented on PROTON-1760:
-------------------------------------

According to http://guides.rubygems.org/name-your-gem/ the gem should be named
"qpid-proton" because Qpid::Proton is a module in a submodule. 

(According to that guide, if the gem is called qpid_proton, then the top-level class/module
should be  QpidProton.)

For the Gem name I don't think there should be a "ruby" prefix or suffix. (The RPM name for
downstream packagers might have something, e.g. fedora would be rubygem-qpid-proton)

I propose to make the change for 0.22 and leave the 0.21 gem in place for backwards compat
- anyone know of any other rules to follow for a name change like this on rubygems.org?


> [ruby-binding] the package name on rubygems.org does not follow conventions
> ---------------------------------------------------------------------------
>
>                 Key: PROTON-1760
>                 URL: https://issues.apache.org/jira/browse/PROTON-1760
>             Project: Qpid Proton
>          Issue Type: Wish
>          Components: ruby-binding
>    Affects Versions: proton-c-0.21.0
>            Reporter: Jiri Daněk
>            Assignee: Alan Conway
>            Priority: Trivial
>             Fix For: proton-c-0.22.0
>
>
> The rubygems.org name is currently {{qpid_proton}}. From a not-so-random sampling, it
seems to me use of dashes is more common than that of underscores. Additionally, the package
in PyPi is called {{python-qpid-proton}}.
> I propose renaming the ruby package to {{qpid-proton}} or {{ruby-qpid-proton}} or even
{{qpid-proton-ruby}}. If possible, which it may not be, by now.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message