qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PROTON-1781) [c-proactor] fix mis-named netaddr functions
Date Tue, 10 Apr 2018 21:17:01 GMT

    [ https://issues.apache.org/jira/browse/PROTON-1781?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16433008#comment-16433008
] 

ASF subversion and git services commented on PROTON-1781:
---------------------------------------------------------

Commit bbe9195e1236a9b3ab367ec629197408f1193e08 in qpid-proton's branch refs/heads/go1 from
[~aconway]
[ https://git-wip-us.apache.org/repos/asf?p=qpid-proton.git;h=bbe9195 ]

PROTON-1781: [c] remove new deprecation warnings for this release

Remove deprecation warnings for these functions. They will be restored in a
future release but we should give people at least one release cycle to adapt to
the new names.

/* These function names will be deprecated in a future release of proton */
/**  @deprecated @{ */
/* PN_DEPRECATED("use pn_transport_local_addr") */
PNP_EXTERN const pn_netaddr_t *pn_netaddr_local(pn_transport_t *t);
/* PN_DEPRECATED("use pn_transport_remote_addr()") */
PNP_EXTERN const pn_netaddr_t *pn_netaddr_remote(pn_transport_t *t);
/* PN_DEPRECATED("use pn_listener_addr()") */
PNP_EXTERN const pn_netaddr_t *pn_netaddr_listening(pn_listener_t *l);
/** @} */


> [c-proactor] fix mis-named netaddr functions 
> ---------------------------------------------
>
>                 Key: PROTON-1781
>                 URL: https://issues.apache.org/jira/browse/PROTON-1781
>             Project: Qpid Proton
>          Issue Type: Improvement
>          Components: proton-c
>    Affects Versions: proton-c-0.21.0
>            Reporter: Alan Conway
>            Assignee: Alan Conway
>            Priority: Major
>             Fix For: proton-c-0.22.0
>
>
> The functions pn_netaddr_remote, pn_netaddr_local and pn_netaddr_listening do not follow
proton's naming conventions - the first part of the name should be the type of the first parameter
to the function. Rename as pn_transport_remote_addr, pn_transport_local_addr and pn_transport_listener_addr



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message