qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ChugR <...@git.apache.org>
Subject [GitHub] qpid-dispatch issue #305: Dispatch 965 - Port to Python 3.x
Date Fri, 18 May 2018 17:53:36 GMT
Github user ChugR commented on the issue:

    https://github.com/apache/qpid-dispatch/pull/305
  
    I ran this branch OK on two systems:
    
    * Fedora 27, Python 2.7
    * Fedora 28, Python 3.6
    
    The F27 system is my development laptop. It has python 2.6, 2.7, 3.3, 3.4, 3.4m, 3.5 3.5m,
3.6, and 3.6m. I believe that my Dispatch build runs python2.7 but to be honest I can't be
sure given all the subprocesses that get launched in dispatch tests.
    
    The F28 system was carefully groomed to have only python 3.6 and 3.6m. On that system
I'm confident that the Dispatch tests ran python 3 all the way. In particular the dispatch
run-time picked up embedded python3. I did not run tox on this system. Tox wants to bring
along all kinds of other versions of python and I wanted as pure of a python3-only system
as I could get.
    
    Great work. Ship it.


---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message