qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gordon Sim (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DISPATCH-997) reusing link name from link closed uncleanly on link routes no longer works
Date Thu, 10 May 2018 13:33:00 GMT
Gordon Sim created DISPATCH-997:
-----------------------------------

             Summary: reusing link name from link closed uncleanly on link routes no longer
works
                 Key: DISPATCH-997
                 URL: https://issues.apache.org/jira/browse/DISPATCH-997
             Project: Qpid Dispatch
          Issue Type: Bug
    Affects Versions: 1.1.0
            Reporter: Gordon Sim
         Attachments: reuse_link_name.py, router-a.conf, router-b.conf, router-c.conf

Attach a link with a specific name that is routed from router A through router B to a 'broker',
then close the connection that attach was sent over without detaching the link. Then try to
reattach (on a new connection) with the same link name. This fails as the attach does not
get successfully routed and now response is received back.

Reproducer: run routers with attached configs router-a, router-b, router-c, then run attached
test script reuse_link_name.py. On 1.0.1, or direct against a single router with no linkrouting,
as expected the test iterates opening a link the closing the connection. With 1.1.0 it gets
stuck on second subscribe attempt.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message