qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ganesh Murthy (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (DISPATCH-1006) QIT 2-node test fails with all brokers
Date Tue, 22 May 2018 13:50:00 GMT

     [ https://issues.apache.org/jira/browse/DISPATCH-1006?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ganesh Murthy resolved DISPATCH-1006.
-------------------------------------
       Resolution: Not A Bug
    Fix Version/s: 1.1.0

The sender was not sending to a link routed address and hence the lack of flow. Once the sender
sends to a link routed address, the problem goes away. Marking this not a bug.

> QIT 2-node test fails with all brokers
> --------------------------------------
>
>                 Key: DISPATCH-1006
>                 URL: https://issues.apache.org/jira/browse/DISPATCH-1006
>             Project: Qpid Dispatch
>          Issue Type: Bug
>            Reporter: Kim van der Riet
>            Assignee: Ganesh Murthy
>            Priority: Major
>             Fix For: 1.1.0
>
>         Attachments: dispatch-2node.qpid-cpp.types.pcapng, qdrouterd.node1.conf, qdrouterd.node1.log,
qdrouterd.node2.conf, qdrouterd.node2.log, qpidd.conf
>
>
> Running the Qpid Interop Test 2-node test using dispatch in the following configuration
fails:
> {noformat}
>           9001        5672        9002
> sender --> node1 --> broker --> node2 --> receiver{noformat}
> Running the test as follows:
> {noformat}
> python -m qpid_interop_test.amqp_types_test --include-type boolean --include-shim ProtonCpp
--sender localhost:9001 --receiver localhost:9002{noformat}
> results in a test hang (until it times out). Looking at the logs, I see when the sender
connects:
> {noformat}
> 2018-05-21 11:47:39.811401 -0400 SERVER (info) Accepted connection to ::1:9001 from ::1:36088
> 2018-05-21 11:47:49.807716 -0400 SERVER (info) Connection from ::1:36088 (to ::1:9001)
failed: amqp:connection:framing-error connection aborted
> {noformat}
> but there is never an AMQP close or error of any kind on the wire (see attached wireshark
file). The test simply hangs until it times out. (If you use Wireshark, it will be necessary
to change the AMQP protocol port from 5672 to 9001 to see this part of the conversation).
> The same occurs if using ActiveMQ and Artemis as the center broker. The same occurs for
all clients, I have tried the ProtonCpp, ProtonPython2, ProtonPython3 and RheaJs clients,
all with the same result. However, running a single-node test works ok.
> Also attached are the two config files for the two dispatch nodes, the config file for
qpid-cpp and the log files for the two dispatch nodes.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org


Mime
View raw message