qpid-proton mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Darryl L. Pierce" <dpie...@redhat.com>
Subject Selectable readable/writable APIs
Date Fri, 14 Mar 2014 21:19:59 GMT
The names are very confusing to me. When I first looked at them they
sounded like boolean methods regaring the readable/writable state of the
underlying descriptor. But from what I've gathered they actually are
methods to _perform_ reading and writing, respectively.

Can we change those names to something more like a verb or an action
phrase  than an adjective? Maybe "receive_bytes" and "send_bytes" or
"read" and "flush"?

Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
Delivering value year after year.
Red Hat ranks #1 in value among software vendors.

View raw message