qpid-proton mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Ross (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PROTON-808) Binaries have their library locations stripped
Date Thu, 12 Feb 2015 19:45:11 GMT

    [ https://issues.apache.org/jira/browse/PROTON-808?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14318854#comment-14318854
] 

Justin Ross commented on PROTON-808:
------------------------------------

I was suggesting the first answer on the SO page:

"""
You should look at set_target_properties command and the property BUILD_WITH_INSTALL_RPATH

http://www.cmake.org/cmake/help/cmake-2-8-docs.html#command:set_target_properties
"""

I know now that you think that's simply the wrong thing to do.
 

> Binaries have their library locations stripped
> ----------------------------------------------
>
>                 Key: PROTON-808
>                 URL: https://issues.apache.org/jira/browse/PROTON-808
>             Project: Qpid Proton
>          Issue Type: Bug
>          Components: proton-c
>            Reporter: Justin Ross
>
> 1. Build proton
> 2. Install to /usr/local
> 3. Run "proton"
> -> Blows up, can't find its library
> https://paste.apache.org/gd56
> http://stackoverflow.com/questions/3352041/creating-binary-with-cmake-removes-runtime-path
> The default behavior of cmake is in my opinion wrong, and we should use the fix mentioned
in that stackoverflow discussion.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message