qpid-proton mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: 0.10 beta2 now available
Date Wed, 05 Aug 2015 16:51:36 GMT
On 4 August 2015 at 17:30, Robbie Gemmell <robbie.gemmell@gmail.com> wrote:
> On 3 August 2015 at 18:40, Robbie Gemmell <robbie.gemmell@gmail.com> wrote:
>> Hi folks,
>>
>> I have put up a 0.10 beta2 cut from the new 0.10.x branch. I'll be
>> looking to cut RC1 in the next couple of days and immediately proceed
>> to vote on it, so please give the beta a kick of the tyres and report
>> back your findings.
>>
>> You can find the files here:
>> https://dist.apache.org/repos/dist/dev/qpid/proton/0.10-beta2/
>>
>> Java binaries are also available in a temporary staging repo at:
>> https://repository.apache.org/content/repositories/orgapacheqpid-1039
>>
>> Robbie
>
> I gave things a kick of the tyres as follows:
> # Verified checksums ok.
> # Checked LICENCE and NOTICE present and look ok.
> # Ran the build and tests via Maven.
> # Ran the build/tests/install via CMake.
> # Built qpid-cpp 0.34 against the above install.
> # Ran the JMS client build+tests from master against the staging repo.
> # Ran the JMS client HelloWorld example against the earlier built 0.34
> cpp broker.
> # Ran the ActiveMQ build + amqp tests from master using the staging repo.
>
> Robbie

During some further checking I noticed that the paths inside the tar
started with ./ which appeared as an initial '.' directory then
containing the qpid-proton-0.10 dir. This was the same for 0.9.1 but
not 0.8, so I figured out what changed and updated the script to avoid
it.

There were also dome issues with some of the docs, which Gordon and
Ken either fixed or discussed why it wasn't an issue.

Robbie

Mime
View raw message