quetz-mod_python-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Treadway" <se...@superchannel.org>
Subject RE: os.system() doesn't work
Date Wed, 17 Dec 2003 21:15:14 GMT
When running under the different process, system commands may have a
different environment.  Your PATH environment variable is used by
os.system to find programs.  Try referencing ssh.exe by its full name
"/usr/bin/ssh.exe" for example, or "c:\path\to\ssh.exe".

-Sean

-----Original Message-----
From: Alberto Sanchez Albarracin [mailto:aalbarracindev@hotmail.com] 
Sent: Wednesday, December 17, 2003 10:09 PM
To: python-dev@httpd.apache.org
Subject: os.system() doesn't work

Anybody can help me with this, i'm doing the following command:
os.system("ssh.exe -i c:\etc\ssh_host_key -l root  192.168.22.14 (cp 
/usr/tmp/test /usr/tmp/test1)")
It seems to do nothing.
I did the ssh.exe in command line and it has worked
I did the same line of code in a .py program out of mod_python and it
has 
worked too
But when i tried it under mod_python it doesn't do anything, no errors
and 
no warnings either.
The user which apache service is started with is the same as the one i
have 
logged in so by command line and py under mod_python use the same user,
so 
it shouldn't be an authenticated trouble because it works in command
line.
Thanks in advance...

_________________________________________________________________
Add photos to your e-mail with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail




Mime
View raw message