quetz-mod_python-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Baster <jam...@nipltd.com>
Subject Re: os.system() doesn't work
Date Wed, 17 Dec 2003 10:34:49 GMT

 From all the symptons you describe it really is sounding like pscp is 
asking for a password or some form of user input from you .... you say 
when you run pscp from the command line it works, but when you do does 
it asked you for a password or for any kind of user input?

James.

Alberto Sanchez Albarracin wrote:

> I don't think this is the problem because if a i try the pscp with a 
> file name that not exist, the pscp doesn't appear in the windows task 
> manager, i mean that if the pscp lacks of some parameter or doesn't 
> find the file doesn't seem to do anything. I've also tried to run the 
> pscp from command line and it has worked so the command line is well 
> formed...
>
>> From: "Gregory (Grisha) Trubetskoy" <grisha@apache.org>
>> To: Alberto Sanchez Albarracin <aalbarracindev@hotmail.com>
>> Subject: Re: os.system() doesn't work
>> Date: Tue, 16 Dec 2003 12:55:24 -0500 (EST)
>>
>>
>> oss.dat probably needs to be a full path, since current working 
>> directory
>> can be anything under mod_python
>>
>> grisha
>>
>> On Tue, 16 Dec 2003, Alberto Sanchez Albarracin wrote:
>>
>> > It could be but this is the two lines of code involved:
>> > s = "pscp -pw root %s root@%s:/usr/tmp/" % ("oss.dat","192.168.22.14")
>> > os.system(s)
>> > Thanks anyway...
>> >
>> >
>> > >From: "Gregory (Grisha) Trubetskoy" <grisha@apache.org>
>> > >To: Alberto Sanchez Albarracin <aalbarracindev@hotmail.com>
>> > >CC: python-dev@httpd.apache.org
>> > >Subject: Re: os.system() doesn't work
>> > >Date: Mon, 15 Dec 2003 22:38:55 -0500 (EST)
>> > >
>> > >
>> > >It's probably asking for a password? Just a guess.
>> > >
>> > >Grisha
>> > >
>> > >On Tue, 16 Dec 2003, Alberto Sanchez Albarracin wrote:
>> > >
>> > > > I'm working with apache 2 and window 2000 server.
>> > > > os.system("pscp somefile user@ipaddress:/usr/tmp") perform pscp 
>> but it
>> > > > doesn't do the remote copy, if i watch the task manager i can 
>> see the
>> > > > pscp.exe task running but it never ends and stays running until I
>> > >restart
>> > > > the operating system.
>> > > > Somebody knows why is it happend? If it is not the way to do a 
>> remote
>> > >copy,
>> > > > can anyone tell me how to do it ??? Thanks in advance...
>> > > >
>> > > > _________________________________________________________________
>> > > > Add photos to your e-mail with MSN 8. Get 2 months FREE*.
>> > > > http://join.msn.com/?page=features/featuredemail
>> > > >
>> >
>> > _________________________________________________________________
>> > Add photos to your messages with MSN 8. Get 2 months FREE*.
>> > http://join.msn.com/?page=features/featuredemail
>> >
>
>
> _________________________________________________________________
> Protect your PC - get McAfee.com VirusScan Online 
> http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963
>
>



Mime
View raw message