quetz-mod_python-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Fraser (JIRA)" <j...@apache.org>
Subject [jira] Created: (MODPYTHON-174) Update requirements to Apache 2.0.47 or greater
Date Fri, 23 Jun 2006 12:51:30 GMT
Update requirements to Apache 2.0.47 or greater
-----------------------------------------------

         Key: MODPYTHON-174
         URL: http://issues.apache.org/jira/browse/MODPYTHON-174
     Project: mod_python
        Type: Task

  Components: documentation  
    Versions: 3.2.7, 3.2.8, 3.2.x    
    Reporter: David Fraser
 Attachments: apache-2.0.47-req-doc.patch

Usage of the apr_table_compress function requires Apache 2.0.47, but the docs only specify
version 2.0.40

See the following URLs for details
http://www.modpython.org/pipermail/mod_python/2006-February/020280.html
http://www.modpython.org/pipermail/mod_python/2006-May/021135.html
http://www.modpython.org/pipermail/mod_python/2006-May/021133.html

More details: apr_table_compress was was committed in r263916 to mod_python.c

Log message:
Fixed crash and memory leak in python_merge_config function in mod_python.c
described in MODPYTHON-75. Boyan Boyadjiev provided the code which corrected
the problem. This also fixes the memory leak resulting in the use of any
PythonOption directive as described in MODPYTHON-60.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message